[US] Performance Issues: Intermittent errors loading Cases dashboards

Incident Report for Torq

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 14:57 UTC

Monitoring

Root Cause Identified: We isolated the intermittent errors to an edge case within a specific query that triggered between 13:26 and 13:35 UTC.

Mitigation: The underlying code path causing the issue has been disabled.

Current Status: Errors have subsided, and we are continuing to monitor the dashboards to ensure stability.
Posted Jun 18, 2026 - 13:45 UTC

Update

Update: We continue to investigate the intermittent errors on the Cases dashboards.
Performance is currently showing signs of improvement.

The team is focused on identifying the root cause.
Posted Jun 18, 2026 - 13:40 UTC

Investigating

We are currently investigating this issue.
Posted Jun 18, 2026 - 13:30 UTC
This incident affected: Administration Portal.