[US] - Workflow executions experiencing degraded performance and missing step data in BuilderBox

Incident Report for Torq

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 12:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2026 - 12:15 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 18, 2026 - 12:07 UTC

Update

Identified - We have identified a potential root cause involving increased load on our database cluster and are currently working on a mitigation plan to restore normal performance levels.

Some workflow executions may still experience delays or missing step data in BuilderBox in the interim.

We will provide another update once the mitigation is underway.
Posted Jun 18, 2026 - 11:50 UTC

Investigating

We are currently investigating an issue with Builderbox where some workflow executions are experiencing degraded performance and failing to return step results.

Our engineering team is actively looking into the root cause, and we will provide updates as more information becomes available. Affected region: US.
Posted Jun 18, 2026 - 11:38 UTC
This incident affected: Workflows Automation.