[US] - Global Cloud Disruption Impacting Workflow Automation in AWS US-EAST-1

Incident Report for Torq

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 02:44 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 02:42 UTC

Update

The affected services are showing improvement.

We're maintaining close monitoring while AWS continues their remediation efforts.
see: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 20:31 UTC

Update

Although we originally observed **signs of recovery** across the affected services, we have seen intermittent impacts to interacts, some operators, and third party services that you may have integrations with.
Posted Oct 20, 2025 - 20:03 UTC

Monitoring

We are starting to observe **signs of recovery** across the affected services.
Posted Oct 20, 2025 - 19:34 UTC

Update

We're seeing improvement in Interactions and some operators.
Schedule Triggers are still not operational.

See: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 17:40 UTC

Identified

The disruption is attributed to a major, ongoing operational issue within the underlying cloud provider's infrastructure (AWS) that appears to be global in scope.

See: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 16:54 UTC

Investigating

Current Status:
We have identified an issue impacting customers in the AWS US-EAST-1 region where Interactions and some operators are failing to run.

Root Cause:

This is not an isolated issue with our platform. The disruption is attributed to a major, ongoing operational issue within the underlying cloud provider's infrastructure (AWS) that appears to be global in scope.

Observed Impact: Any workflows with a Interactions are failing.

Observed Scope: Multiple major services (e.g., Atlassian) are also impacted.
Posted Oct 20, 2025 - 16:30 UTC
This incident affected: Workflows Automation.