Scheduled Services Maintenance

Scheduled for May 10, 07:00 - 09:00 UTC

Update

Scheduled maintenance window for routine service updates and improvements.

No impact expected. Services will remain fully operational throughout the maintenance window.
Posted May 07, 2026 - 07:20 UTC

Scheduled

Scheduled maintenance window for routine service updates and improvements.

No impact expected. Services will remain fully operational throughout the maintenance window.
Posted May 07, 2026 - 07:18 UTC
This scheduled maintenance affects: Workflows Automation, Administration Portal, and Case Management.