Issue with google based logins
Incident Report for Torq
Resolved
This incident has been resolved.
Posted Aug 17, 2023 - 14:10 UTC
Investigating
We are currently investigating this issue.
Posted Aug 17, 2023 - 13:30 UTC
This incident affected: Administration Portal.