[US] Slowness in non-accelerated steps

Incident Report for Torq

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 01:41 UTC

Update

The issue have been identified and remediated, workflow automation is operational
Posted Nov 14, 2025 - 01:40 UTC

Identified

We've identified that the slowness in non-accelerated steps is caused by an ongoing Google Kubernetes Engine (GKE) incident.
Google Cloud Platform has confirmed: "We are experiencing an issue with Google Kubernetes Engine. Our engineering team continues to investigate the issue."
We are monitoring the situation closely and will provide updates as they become available.
Posted Nov 13, 2025 - 20:02 UTC

Investigating

We are currently investigating this issue.
Posted Nov 13, 2025 - 18:30 UTC
This incident affected: Workflows Automation.