[US] Delayed workflow executions

Incident Report for Torq

Resolved

This incident has been resolved.
Posted May 27, 2026 - 19:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 27, 2026 - 17:35 UTC
This incident affected: Workflows Automation.