[EU+US] - Intermittent failures when searching for steps in the workflow builderbox

Incident Report for Torq

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 17:35 UTC

Update

We've identified this is caused by an Azure OpenAI service disruption and are actively working on implementing a fallback solution.
Posted Jan 27, 2026 - 16:00 UTC

Monitoring

We're investigating reports that step searches in the builder are not working

What's happening:
Some users are experiencing intermittent failures when searching for steps in the workflow builder.
Some searches return errors instead of results.

Impact:
Step search functionality is experiencing intermittent errors in US and EU regions.

Workaround: You can still add steps by manually browsing the step catalog, or retry the search.

Status:
We've identified this is caused by an Azure OpenAI service disruption and are actively working on implementing a fallback solution.
Posted Jan 27, 2026 - 11:15 UTC
This incident affected: Administration Portal.