System Outage

Incident Report for Torq

Resolved

We are seeing a return to normal operations.
Posted Jun 12, 2025 - 21:16 UTC

Update

GCP have implemented a fix in the US and EU region and are currently monitoring its recovery.
Posted Jun 12, 2025 - 20:56 UTC

Monitoring

GCP have implemented a fix in the EU region and are currently monitoring its recovery.
Meanwhile, GCP is still addressing the issues in the US region.
Posted Jun 12, 2025 - 20:26 UTC

Update

GCP have implemented a fix in the EU region and are currently monitoring its recovery.
Meanwhile, GCP is still addressing the issues in the US region.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 20:26 UTC

Update

GCP have implemented a fix in the EU region and are currently monitoring its recovery.
Meanwhile, GCP is still addressing the issues in the US region.
Posted Jun 12, 2025 - 19:47 UTC

Update

We have identified that the current elevated error rates are a result of an ongoing outage impacting GCP, and associated services.
We will continue to provide updates as we work to resolve these ongoing impacts.
https://status.cloud.google.com/
Posted Jun 12, 2025 - 18:52 UTC

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 18:30 UTC

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 18:27 UTC

Investigating

We are currently experiencing an issue with our cloud provider that is affecting system performance and availability across both our US and EU regions.
Posted Jun 12, 2025 - 18:27 UTC
This incident affected: Workflows Automation, Administration Portal, and Case Management.